Commit 1a75d3be authored by Nick Elsmore's avatar Nick Elsmore

Add required dependencies for multistrap

parent 65fa0cfc
......@@ -11,6 +11,8 @@ ENV ENTRYPOINT ${ENTRYPOINT:-/docker-entrypoint.sh}
RUN DEBIAN_FRONTEND=noninteractive \
apt-get update \
&& apt-get install -y -q \
sudo \
locales \
git-core \
gnupg \
flex \
......@@ -23,10 +25,15 @@ RUN DEBIAN_FRONTEND=noninteractive \
python \
bc \
multistrap \
apt-transport-https \
debian-keyring \
debian-archive-keyring \
libc6-dev-armhf-cross \
qemu-user-static \
&& apt-get clean
RUN locale-gen en_US.UTF-8
RUN curl http://storage.googleapis.com/git-repo-downloads/repo > /usr/local/bin/repo \
&& chmod a+x /usr/local/bin/repo
......@@ -44,5 +51,7 @@ RUN chmod 600 /home/docker/.ssh/config \
COPY ./docker-entrypoint.sh /
RUN chmod a+x /docker-entrypoint.sh
RUN ln -s /home/docker/pyra-build/multistrap/pyra /usr/share/multistrap/pyra
USER docker
ENTRYPOINT ["/docker-entrypoint.sh"]
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment